An error in 10.6 Snow Leopard

Post Reply
shhong
Posts: 9
Joined: Wed Jan 07, 2009 6:52 am

An error in 10.6 Snow Leopard

Post by shhong » Tue Sep 08, 2009 12:15 am

I got the following error in 10.6

Code: Select all

bash$ nrniv /Applications/NEURON/nrn/share/nrn/lib/hoc/stdrun.hoc
NEURON -- Release 7.0 (285:80827e3cd201) 2009-01-16
Duke, Yale, and the BlueBrain Project -- Copyright 1984-2008
See http://www.neuron.yale.edu/credits.html

nrniv(53939) malloc: *** error for object 0x100cabe58: incorrect checksum for freed object - object was probably modified after being freed.
*** set a breakpoint in malloc_error_break to debug
Abort trap
This is compiled with

Code: Select all

./configure --prefix=/Applications/NEURON/nrn --with-iv=/Applications/NEURON/iv/ --x-includes=/usr/X11/include --x-libraries=/usr/X11/lib --with-pic --with-mpi --with-nrnpython CFLAGS='-O3 -arch x86_64 -m64 -fPIC -mfpmath=sse -msse3' CXXFLAGS='-O3 -arch x86_64 -m64 -fPIC -mfpmath=sse -msse3'

hines
Site Admin
Posts: 1580
Joined: Wed May 18, 2005 3:32 pm

Re: An error in 10.6 Snow Leopard

Post by hines » Tue Sep 08, 2009 11:08 am

Please try the latest alpha version tar.gz found at
http://www.neuron.yale.edu/ftp/neuron/versions/alpha/
or, if you have mercurial installed, even better to get the mercurial repository sources from:
http://www.neuron.yale.edu/hg/neuron/nrn/

shhong
Posts: 9
Joined: Wed Jan 07, 2009 6:52 am

Re: An error in 10.6 Snow Leopard

Post by shhong » Tue Sep 08, 2009 10:58 pm

I got the same error with the mercurial repository sources (344). nrniv seems to work, but also stops when nrngui.hoc is loaded.

shhong
Posts: 9
Joined: Wed Jan 07, 2009 6:52 am

Re: An error in 10.6 Snow Leopard

Post by shhong » Wed Sep 09, 2009 12:09 am

I also discovered that build.sh of iv cannot generate config.*, which makes configure fail.

wvangeit
Posts: 21
Joined: Wed Jun 11, 2008 2:14 am

Re: An error in 10.6 Snow Leopard

Post by wvangeit » Sun Sep 13, 2009 9:05 pm

I'm having exactly the same problem after installing (i.e. compiling from source) it on a new Snow Leopard.

hines
Site Admin
Posts: 1580
Joined: Wed May 18, 2005 3:32 pm

Re: An error in 10.6 Snow Leopard

Post by hines » Wed Sep 16, 2009 7:56 am

Sorry I forgot to subscribe to this topic.
So far, compiling from the sources founders on a problem with --framework-carbon.
Just to see if there is a problem with the existing alpha distribution, someone please
install
http://www.neuron.yale.edu/ftp/neuron/v ... 0.4.11.dmg
and let us know if it works.

btorb
Posts: 30
Joined: Fri Oct 21, 2005 8:14 am

Re: An error in 10.6 Snow Leopard

Post by btorb » Thu Sep 17, 2009 8:41 pm

shhong and wvangeit came up with this solution which seems to work. (which works for the latest development code downloaded with mercurial)

Code: Select all

./build.sh 
at this point, automake fails to create the "config.sub" and "config.guess". copy these two files from either the downloadable tarball or from a previous installation (as I did). Then proceed with the following:

Code: Select all

./configure --prefix=$IDIR/nrn --build=i386 --with-iv=$IDIR/iv --with-nrnpython  --with-paranrn CFLAGS="-O3 -arch i386" CXXFLAGS="-O3 -arch i386" 
make sudo make install
in my case, IDIR=/Applications/NEURON-dev3, and i installed iv (with the nearly identical ./configure) to $IDIR/iv

All my code seems to run again although an error is given: special(83688) malloc: *** error for object 0x968e80: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug

hines
Site Admin
Posts: 1580
Joined: Wed May 18, 2005 3:32 pm

Re: An error in 10.6 Snow Leopard

Post by hines » Fri Sep 18, 2009 7:26 am

Ok. Since there is no --enable-carbon configure arg, then that makes an x11 version.
Does x11 come along whenever the development environment is installed?
I'd still like to know if the
http://www.neuron.yale.edu/ftp/neuron/v ... 0.4.11.dmg
works. If not, I can make an OS X 10.5 version and that can be tried.

hines
Site Admin
Posts: 1580
Joined: Wed May 18, 2005 3:32 pm

Re: An error in 10.6 Snow Leopard

Post by hines » Wed Sep 23, 2009 8:42 am

automake fails to create the "config.sub" and "config.guess"
Snow Leopard uses glibtool version 2.2.4 and that requires an extra argument to glibtoolize.
Edit build.sh and change
glibtoolize -c -f
to
glibtoolize -c -f -i
You should do that both in the iv and nrn build.sh files.
Sadly glibtool version 1 series does not allow this '-i' arg so to update the script I will eventually
have to switch to the version 2 series myself or put in a test. I'd switch to the new one but I cannot
get libtool version 2 series to work properly on my x86_64 centos5 machine.

Code: Select all

nrniv(53939) malloc: *** error for object 0x100cabe58: incorrect checksum for freed object...
Apparently snow leopard's posix_memalign does not work properly. Or perhaps it is a problem with gcc 4.2.1.
Anyway, a work around is to edit nrn/src/oc/symbol.c and change
#if HAVE_POSIX_MEMALIGN
to
#if 0 && HAVE_POSIX_MEMALIGN
I would expect this problem to go away when apple makes an update.

I see that the osx 10.4 built alpha version
http://www.neuron.yale.edu/ftp/neuron/v ... 0.4.11.dmg
works properly.

Post Reply