nrnivvmodel compile error

Post Reply
mattnolan
Posts: 6
Joined: Thu Mar 05, 2009 11:39 am

nrnivvmodel compile error

Post by mattnolan »

I'm trying to compile mod files with nrnivmodl (Neuron version 7) running on fedora 10 with gcc4.3.2.

I receive the following error message:

/usr/bin/ld: cannotfind -lncurses
make: *** [libnrnmech.la] Error 1

I'm new to fedora so may be missing something simple. Any suggestions?

Thanks,

Matt
ted
Site Admin
Posts: 5784
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: nrnivvmodel compile error

Post by ted »

The development environment is incomplete. If you did not use the "gui software installer" to select the default "development" bundle, then do so and that may fix the problem.

If you did, you need to get at least one more item: the library for libncurses. Bring up the gui software installer tool, and search for package names that include the string ncurses. Select the most recent lib*ncurses and install that.
mattnolan
Posts: 6
Joined: Thu Mar 05, 2009 11:39 am

Re: nrnivvmodel compile error

Post by mattnolan »

Thanks. That worked!
ted
Site Admin
Posts: 5784
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: nrnivvmodel compile error

Post by ted »

Great!
Post Reply