voltage plot bug in network plot

Using the graphical user interface to build and exercise models. Includes customizing the GUI by writing a little bit of hoc.
Post Reply
mgoldman

voltage plot bug in network plot

Post by mgoldman »

I have created a simple neuron with the cell builder and a simple NetStim that I have connected to the neuron with the NetBuilder. When I do this in version 5.8 it works fine. However, my student just downloaded version 5.9 and we have both tried doing the exact same thing with the following bug:

When we go to set up a voltage plot and use "Plot What" we can select the cell (in the left panel, by double-clicking), then the section (in the middle panel, by double-clicking). However, when we double-click on the section in the middle panel, nothing pops up in the right-hand panel (where we would normally choose to plot the voltage and specify the location along the section). Again, the voltage DOES pop up in version 5.8 (dated Oct. 14, 2005) but DOES NOT pop up in the new version 5.9. This is completely crippling to us because we can't plot anything and aren't sure if NEURON has crashed more thoroughly.

Please help by explaining this and/or reposting the old version 5.8 so that we can work from that non-faulty version of NEURON.

Also of note, this was done on windows XP and we have experienced the same problem cited in an earlier posting to the "Windows" section of this user group forum: namely, whenever we click on "Save session" or "working directory" we get an error message at the oc prompt. Again, this error did not occur in version 5.8. I don't know if this and our other problem are related, e.g. if in both cases, NEURON version 5.9 can't find a relevant file.
ted
Site Admin
Posts: 5810
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Post by ted »

Under WinXP Pro, logged in as myself (not Administrator), I just used version 5.9
2006-5-20 18:55:15 Main (39) to construct a network with a single compartment
soma, to which an ExpSyn is attached, and a NetStim that drives the ExpSyn.
Set weight to 0.001, clicked on the Network Builder's Create button, brought up a
RunControl and a voltage axis graph, used Plot what? to select (by double clicking)
cell_Cell_
instance 0.
soma
and the right field of the Plot what? tool showed a list of all range variables associated
with soma, including v(0.5). Completed selection of the variable ( i.e.
cell_Cell[0].soma(v(0.5) ) and everything worked fine, including the graph.

Incidentally, there's no need to construct the variable name by double clicking. At any
point you can click in the edit field and start typing. I usually let the tool take care of
the most tedious stuff (everything that precedes the name of the section), and then
finish by typing the name of the section etc.

Then I saved everything to a session file and exited NEURON. Finally, I started
NEURON again, loaded the session file, and ran another simulation. Worked fine again.
I'll send you the session file if you like.

Exactly what version of NEURON are you using? i.e. what is all that stuff that NEURON
prints on the first line of its xterm when it starts up?
whenever we click on "Save session" or "working directory" we get an error message at the oc prompt.
This has nothing to do with your other question. It may not even have anything to do
with NEURON. On my PC with a reasonably recent update of XP Pro,
non-Administrators are not allowed to write to c:\. I don't recall trying to write anything
to c:\ on this machine before, so I can't say that this "protection" of c:\ isn't the result
of a recent "automatic update" from our friends at MicroSloth.

When you start NEURON by double-clicking on nrngui, the working directory is c:\.
NEURON Main Menu / File / working directory
produces this message

Code: Select all

oc: Permission denied
nrniv: errno set during call of File[1].chooser
 near line 2
 {change_working_dir()}
which apparently only means that you don't have write privileges there. The tool
still works anyway. After moving to the directory of my choice, another
Permission denied
appears, but the directory change happens. Something similar occurs when I try
load session, save session, load hoc, or load dll, without first using working directory
or recent directory to move somewhere other than c:\

So did you actually have trouble saving a session file, or are you only reporting that you
saw a
Permission denied
message? If you are not able to save a session file, have you tried moving to a
user-writable directory first?
Post Reply