bison 2.4 and parse.y

Post Reply
jyamad

bison 2.4 and parse.y

Post by jyamad »

Compiling in Gentoo Linux, using Bison 2.4.1, fails with a bison midrule error. This can be easily recreated by using bison directly on the offending file:

$ bison -y src/oc/parse.y
src/oc/parse.y:379.32-33: $$ for the midrule at $3 of `stmt' has no declared type
src/oc/parse.y:390.32-33: $$ for the midrule at $4 of `stmt' has no declared type
src/oc/parse.y:526.12-13: $$ for the midrule at $1 of `section_or_ob' has no declared type

More is said about this error here: http://www.archivum.info/help-bison@gnu ... lared_type. I do not know enough about bison to build a patch.

I am happy to provide more information about my environment, but it seems the problem is with bison-2.4 catching more errors than it used to. If I understand the problem, adding types to parse.y should be fully backward compatible.

Thanks!
-Jason
hines
Site Admin
Posts: 1600
Joined: Wed May 18, 2005 3:32 pm

Re: bison 2.4 and parse.y

Post by hines »

jyamad

Re: bison 2.4 and parse.y

Post by jyamad »

thanks. this works great.
Post Reply