Page 1 of 1

Windows 10 install problem

Posted: Wed Nov 21, 2018 8:04 pm
by neuralian
I downloaded and installed NEURON 7.6.2. master (f5a1284) under Windows 10. This is a new installation - NEURON has not been loaded/run on this machine before.

I have set (and checked) paths according to the instructions.

Python is alive and well and discoverable from the Command Prompt:


Python 3.6.5 |Anaconda, Inc.| (default, Mar 29 2018, 13:32:41) [MSC v.1900 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.


Double-clicking the nrngui icon on Start menu gives the following error message:


cygpath: unknown option -- U
Try `cygpath --help' for more information.
NEURON -- VERSION 7.6.2 master (f5a1284) 2018-08-15
Duke, Yale, and the BlueBrain Project -- Copyright 1984-2018

Could not load libnrnpython-3
pyver10=0 pylib=D:/Users/paumi69p/Anaconda3/new/pkgs/python-3.6.5-h0c2934d_0/python36.dll
0 C:\nrn\bin\nrniv.exe: can't open C:/nrn/mingw/lib/hoc/nrngui.hoc


This is unsurprising in the sense that the file nrngui.hoc does not exist at that location. Indeed, that location does not exist - C:/nrn/mingw/ does not have a /lib subdirectory. The correct path would appear to be C:/nrn/lib/hoc/nrngui.hoc. I tried moving /lib from /nrn to /mingw, but then it fails to start (a window flashes momentarily, but vanishes without an error message).

I guess I need to edit a path(s) somewhere?

NB (Most of) the demos run, or appear to, if I launch them from nrn/demo.


Re: Windows 10 install problem

Posted: Sun Dec 02, 2018 4:49 pm
by neuralian
To clarify: I've installed as per instructions but nrngui does not run.
I have Python 3.6.5 and Python 2.7.15 installed.
Environment variables and path all appear to be correct.
I've tried running from a 2.7 environment in Anaconda - still no joy.
when I run nrngui, nrniv.exe looks for nrngui.hoc in the wrong place & crashes.

Re: Windows 10 install problem

Posted: Thu Dec 20, 2018 3:09 pm
by hines
NEURON -- VERSION 7.6.2 master (f5a1284) 2018-08-15
The latest standard distribution is 7.6.3.
I have hope but not certainty that that will fix your problem. At any rate it makes sense to begin diagnosing with that as there have
been a few changes in the files that would be related to your issues.