5.9 DMG can't open library: /usr/lib/libncurses.5.4.dylib

Post Reply
Posts: 29
Joined: Tue Oct 04, 2005 3:29 pm
Location: Ohio University

5.9 DMG can't open library: /usr/lib/libncurses.5.4.dylib

Post by jaambros »

I tried installing the 5.9.39-powerpc-apple-darwin8.6.0.dmg in /Applications on a 10.3.9 G5 powerpc but get the following error when I double clicked the neurondemo.
Same error when trying from the command line.

Code: Select all

dyld: /Applications/NEURON-5.9/nrn/powerpc/bin/nrniv.app/Contents/MacOS/nrniv can't open library: /usr/lib/libncurses.5.4.dylib  (No such file or directory, errno = 2)
/Applications/NEURON-5.9/nrn/share/nrn/demo/neuron: line 12:  5403 Trace/BPT trap          "${NRNIV}" -dll "${NRNHOME}/share/nrn/demo/release/powerpc/.libs/libnrnmech.so" "$@"
neurondemo exit status was 133
Press return key to exit
Also tried nrn-5.9-1439-powerpc-apple-darwin8.6.0.dmg with the same results.

Any suggestions on how to fix this?


Post by zhbrass »

my advice would be to download NEURON 5.8 or upgrade to Mac OS 10.4.x. I don't think that NEURON 5.9 will run in panther
Posts: 1
Joined: Fri Sep 22, 2006 8:19 pm

Post by kreek »

yes he is correct version 5.9 is only for Tiger 10.4 as libncurses.5.4 is only on this platform you would have to use version 5.8 since it supports libncurses.5.0
Post Reply