InterViews compilation problem with gcc on 10.5.1

Post Reply
avicenna
Posts: 16
Joined: Wed Aug 15, 2007 4:06 pm

InterViews compilation problem with gcc on 10.5.1

Post by avicenna »

While trying to compile the version of InterViews that accompanies neuron 6.1 on MacOSX 10.5.1 (Intel) with gcc 4.0.2, I observed the following errors after running configure with the --with-x option specified:
Making all in src
Making all in lib
g++ -DHAVE_CONFIG_H -I. -I. -I../include -I/usr/X11/include -g -O2 -c Dispatch/dispatcher.cpp -fno-common -DPIC -o Dispatch/.libs/dispatcher.o
Dispatch/dispatcher.cpp: In member function 'osboolean dpFdMask::isSet(int) const':
Dispatch/dispatcher.cpp:113: error: invalid conversion from 'const fd_set*' to 'fd_set*'
Dispatch/dispatcher.cpp:113: error: initializing argument 2 of 'int __darwin_fd_isset(int, fd_set*)'
Dispatch/dispatcher.cpp: In member function 'osboolean dpFdMask::anySet() const':
Dispatch/dispatcher.cpp:129: error: invalid conversion from 'const fd_set*' to 'fd_set*'
Dispatch/dispatcher.cpp:129: error: initializing argument 2 of 'int __darwin_fd_isset(int, fd_set*)'
Dispatch/dispatcher.cpp: In member function 'int dpFdMask::numSet() const':
Dispatch/dispatcher.cpp:141: error: invalid conversion from 'const fd_set*' to 'fd_set*'
Dispatch/dispatcher.cpp:141: error: initializing argument 2 of 'int __darwin_fd_isset(int, fd_set*)'
make[2]: *** [Dispatch/dispatcher.lo] Error 1

(snip)
hines
Site Admin
Posts: 1600
Joined: Wed May 18, 2005 3:32 pm

Post by hines »

That is fixed in the svn repository. But others have also had problems compiling
under 10.5 even with carbon.
I just received osx 10.5 and an external drive so I can install it without losing 10.4.
In a few days should be able to update whatever needs to be updated and will put a new dmg and tar.gz in the alpha distributon directory.
avicenna
Posts: 16
Joined: Wed Aug 15, 2007 4:06 pm

Post by avicenna »

Thanks; much appreciated.
hines
Site Admin
Posts: 1600
Joined: Wed May 18, 2005 3:32 pm

Post by hines »

avicenna
Posts: 16
Joined: Wed Aug 15, 2007 4:06 pm

Post by avicenna »

I was able to compile iv and neuron successfully with the --with-x option specified. As with older versions of neuron, the GUI would not display with X11; I'm going to try to recompile against carbon.
hines
Site Admin
Posts: 1600
Joined: Wed May 18, 2005 3:32 pm

Post by hines »

Now that I have 10.5, I will build with
x11 over the weekend and see what happens.
hines
Site Admin
Posts: 1600
Joined: Wed May 18, 2005 3:32 pm

Post by hines »

I didn't experience any gui problems with osx 10.5 and x11.
I built using

Code: Select all

  350  cd ivx11
  351  sh build.sh
  352  ./configure --prefix=`pwd`
  353  make
  354  make install
cd ..
  358  mkdir nrnx11
  359  cd nrnx11
  362  ../nrn/configure --prefix=`pwd` --srcdir=../nrn --with-nrnpython --with-iv=$HOME/neuron/ivx11
  363  make
  364  make install
launched x11 from /Applications/Utilities/X11
and then in the xterm that pops up:

Code: Select all

bash-3.2$ echo $DISPLAY
/tmp/launch-VJaEjE/:0
cd ....
bash-3.2$ ./nrngui
NEURON -- VERSION 6.2.991 (1980) 2008-02-13
Duke, Yale, and the BlueBrain Project -- Copyright 1984-2007
See http://www.neuron.yale.edu/credits.html

nrniv: unable to open font "*Arial*bold*--12*", using "fixed"

and everything seems to work well.
The only question I have is one related to other difficulties
experienced by osx 10.5 upgraders. Did you also upgrade your
developer tools?
avicenna
Posts: 16
Joined: Wed Aug 15, 2007 4:06 pm

Post by avicenna »

Which developer tools? I have Xcode 3.0 installed.
hines
Site Admin
Posts: 1600
Joined: Wed May 18, 2005 3:32 pm

Post by hines »

Whatever came with the Leopard dvd.
Post Reply