Page 1 of 1

MPI simulation hangs

Posted: Fri Oct 11, 2019 6:09 pm
by pascal
I have a network simulation that runs just fine in serial, and it used to also work in parallel until I re-organized the code a bit (placing different classes in different files, and wrapping the code to actually run the simulation in its own function). The simulation periodically dumps data to file, and when I run it in parallel it just hangs at the first data dump, never actually dumping anything to file. I'm not sure how to even approach debugging this, since not all print statements will print to the screen in parallel.

Thoughts on where I can start?

Re: MPI simulation hangs

Posted: Fri Oct 11, 2019 7:34 pm
by pascal
Upon further investigation, this appears to be an installation problem. I ran the exact same code on a different computer, and it had no issues running in parallel, completing the simulation perfectly (and giving identical results to a serial simulation). Both computers were running Windows 10, and I thought I'd installed NEURON, Python, and MPI in the same way (using the Anaconda distribution for Python 3, and Microsoft's MPI distribution).