Bug in MulRunFitter patch from Aaron Luchko

Using the Multiple Run Fitter, praxis, etc..
Post Reply
Keivan
Posts: 127
Joined: Sat Apr 22, 2006 4:28 am

Bug in MulRunFitter patch from Aaron Luchko

Post by Keivan » Tue Dec 07, 2010 2:37 pm

After I've update my neuron to latest development update, it behave buggy. during iteration everything goes well (neuron can find optimized parameter), but after iterations neuron report initial (starting) parameters.

hines
Site Admin
Posts: 1580
Joined: Wed May 18, 2005 3:32 pm

Re: Bug in MulRunFitter patch from Aaron Luchko

Post by hines » Tue Dec 07, 2010 8:36 pm

Glad you found that so quickly. The fix is in
http://www.neuron.yale.edu/hg/neuron/nr ... 8cf9af38b9

Keivan
Posts: 127
Joined: Sat Apr 22, 2006 4:28 am

Re: Bug in MulRunFitter patch from Aaron Luchko

Post by Keivan » Wed Dec 08, 2010 2:36 pm

Thank you for the fix.It works.

Is there a way to download patch instead of using hg clone command?

Keivan
Posts: 127
Joined: Sat Apr 22, 2006 4:28 am

Re: Bug in MulRunFitter patch from Aaron Luchko

Post by Keivan » Fri Dec 10, 2010 3:01 pm

I found another bug: "number of runs" do not reset with each press of "optimize" button.
Also, a feature I miss in the previous version was the amount of minimum error reported in the console. Because, GUI rounds the error and make it impossible to track slight changes in the error (to prevent local minimums).

hines
Site Admin
Posts: 1580
Joined: Wed May 18, 2005 3:32 pm

Re: Bug in MulRunFitter patch from Aaron Luchko

Post by hines » Fri Dec 10, 2010 6:49 pm

Those are fixed in
http://www.neuron.yale.edu/hg/neuron/nr ... a2efe63148
You can get a patch (without having hg) by viewing the above url, selecting "raw",
copying the page to a file on your machine and then executing in the
nrn source directory:
patch -p 1 < patch_file_you_created

Keivan
Posts: 127
Joined: Sat Apr 22, 2006 4:28 am

Re: Bug in MulRunFitter patch from Aaron Luchko

Post by Keivan » Sat Dec 11, 2010 12:36 am

Thanks a lot

Keivan
Posts: 127
Joined: Sat Apr 22, 2006 4:28 am

Re: Bug in MulRunFitter patch from Aaron Luchko

Post by Keivan » Mon Feb 07, 2011 3:21 pm

I use multirun-fitter in parallel mode. when I press stop button or at the end of fitting , one cpu core remain active.

also, in gentoo linux I receive this error:

Code: Select all

 "X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Further messages for error code 9 will not be shown"
also, I can't run my previous session files.
error:

Code: Select all

nrniv: Expecting string argument
 in MRFGoldSigReal.ses near line 30
 opt.set_optimizer(new MulfitPraxWrap(p.pf))
                                            ^
        OptimizerWrap[0].set_optimizer(...)
      xopen("MRFGoldSigReal.ses")
    execute1("{xopen("MRFGoldSigReal.ses")}")
  load_file("MRFGoldSigReal.ses")
        0 
/home/keivan/neuron/nrn/x86_64/bin/nrniv: syntax error
 in MRFGoldSigReal.ses near line 31
 {object_push(opt.optimizer)}
^

hines
Site Admin
Posts: 1580
Joined: Wed May 18, 2005 3:32 pm

Re: Bug in MulRunFitter patch from Aaron Luchko

Post by hines » Tue Feb 08, 2011 7:56 am

Edit your session file and replace:
opt.set_optimizer(new MulfitPraxWrap(p.pf))
with
opt.set_optimizer("MulfitPraxWrap")

With regard to the multirun-fitter in parallel mode, I'm confused about how you are launching NEURON.
Years ago when I switched from PVM to MPI, I've never run an interactive parallel job but
have been restricted to batch mode.
In fact the -mpi arg turns off the gui. Whenever I see the "|| Optimize" button I think that I should remove
it until the question of running an interactive MPI job is resolved. I think what I will do is check to
see if the value of ParallelContext.nhost() == 1 during the creation of the MultipleRunFitter GUI and
if so, NOT create the "|| Optimize" button.

hines
Site Admin
Posts: 1580
Joined: Wed May 18, 2005 3:32 pm

Re: Bug in MulRunFitter patch from Aaron Luchko

Post by hines » Tue Feb 08, 2011 8:10 am

Ironically, the "|| Optimize" button was never supposed to be showing but was testing
a long obsolete value for pc.nhost. This has been fixed,
http://www.neuron.yale.edu/hg/neuron/nr ... 0a186b8173

If you can get that button to show again, then it will be time to fix any bugs that crept in
during the evolution of the MPI version. Of course, if you are running in batch mode
and have called MulRunFitter.paropt() (hard to do directly since it is not public)
it would also raise the problem to a higher position on my stack of things to do.

Keivan
Posts: 127
Joined: Sat Apr 22, 2006 4:28 am

Re: Bug in MulRunFitter patch from Aaron Luchko

Post by Keivan » Tue Feb 08, 2011 12:52 pm

Dear My friend
your patch did not fixed the problem. I will send you the simulation to see it for yourself.
news: this problem did not exist in my windows laptop.

Post Reply