Search found 8 matches

by NickHananeia
Mon Jul 12, 2021 11:36 am
Forum: Adding new mechanisms and functions to NEURON
Topic: Strangeness when recording state variable
Replies: 6
Views: 99

Re: Strangeness when recording state variable

Still working on this... Moving back to an older version of NEURON didn't remedy the situation but at this point I'd want to be sure that nothing is wrong with Vector.record. Testing my code - calcium accumulation does work - if I ask for cai after the simulation has run, it gives me an answer that ...
by NickHananeia
Fri Jul 09, 2021 6:57 am
Forum: Adding new mechanisms and functions to NEURON
Topic: Strangeness when recording state variable
Replies: 6
Views: 99

Re: Strangeness when recording state variable

It seems that the variable does not exist (or at least doesn't exist when the code goes to look for it). Trying to print it gives me the error "cai suffix not a range variable or section property", or "cai undefined function" if I use your second print line. The parameters of the...
by NickHananeia
Thu Jul 08, 2021 8:07 am
Forum: Adding new mechanisms and functions to NEURON
Topic: Strangeness when recording state variable
Replies: 6
Views: 99

Strangeness when recording state variable

So, I'm checking that our calcium concentration stuff is working properly (we're using a few v-gated Ca channels) with the Ca_DynamicsE2.mod that looks like this: : Dynamics that track inside calcium concentration : modified from Destexhe et al. 1994 NEURON { SUFFIX CaDynamics_E2 USEION ca READ ica ...
by NickHananeia
Tue May 11, 2021 10:33 am
Forum: Other questions
Topic: Discrepancy between tvec and vector
Replies: 2
Views: 165

Re: Discrepancy between tvec and vector

That makes sense. I'd shifted to using the indgen method because of another issue, but I found a workaround for that.

Thanks for the quick solution!
by NickHananeia
Tue May 11, 2021 8:38 am
Forum: Other questions
Topic: Discrepancy between tvec and vector
Replies: 2
Views: 165

Discrepancy between tvec and vector

I hope this is something minor that I'm missing, but I've noticed a weird discrepancy between my tvec and a voltage vector when I need 1:1 correspondence, but only depending on the time step. The program that I've written has a selectable time step as a parameter: 5us or 25us, and this is set pretty...
by NickHananeia
Fri Dec 11, 2020 2:48 pm
Forum: MSWin
Topic: Unable to find Import3d_Neurolucida3
Replies: 4
Views: 600

Re: Unable to find Import3d_Neurolucida3

Ah, found the problem - their import line was placed in the wrong place relative to the template opening.

Thanks for pointing me in the right direction.
by NickHananeia
Thu Dec 10, 2020 10:28 am
Forum: MSWin
Topic: Unable to find Import3d_Neurolucida3
Replies: 4
Views: 600

Re: Unable to find Import3d_Neurolucida3

The code is not published in ModelDB; it is posted in the Human Brain Project collaboratory. If it helps, their invocation of the function looks like this: proc load_morphology(/* morphology_dir, morphology_name */) {localobj morph, import, sf, extension strdef morph_path sprint(morph_path, "%s...
by NickHananeia
Wed Dec 09, 2020 11:51 am
Forum: MSWin
Topic: Unable to find Import3d_Neurolucida3
Replies: 4
Views: 600

Unable to find Import3d_Neurolucida3

Hi, I've been working on an adaptation of a published model, and in attempting to run their code, I get an error in NEURON when their code attempts to load the morphology files, reading "Import3d_Neurolucida3 is not a template". I've been running NEURON fine for months on this machine, and...