Page 1 of 1

Installation Issues

Posted: Wed Sep 05, 2018 11:01 am
by samnemo
If anyone has installation issues/questions, please let us know. We can help troubleshoot any problems here. Also note, that to simplify the HNN installation process, we have created Virtual Box application images, available at .

Re: Installation Issues

Posted: Tue Sep 18, 2018 6:09 pm
by axiezai
I am trying to install HNN on ubuntu 16, and I have python3 installed with conda, and my native python --version = 2.7.12

So when I run the script, line 13 does a sudo apt install, the sudo command basically places all the installed packages under python 2.7.12, while by default python is set to the python version that's installed with conda. So when I run the hnn, all the packages that was installed are not found.

I'm wondering if I can just replace your 'sudo apt install' with 'pip install'? And are there package versions I should be careful about?

Please let me know! Thanks!

Re: Installation Issues

Posted: Tue Sep 18, 2018 10:16 pm
by ramcdougal
Strictly speaking, the command on the installer's line 13

Code: Select all

sudo apt install -y python3-pyqt5 python3-pip python3-pyqtgraph python3-opengl zlib1g-dev zlib1g zlibc libx11-dev mercurial bison flex automake libtool libxext-dev libncurses-dev python3-dev xfonts-100dpi cython libopenmpi-dev python3-scipy 
puts the PyQt5 module on the path of the Ubuntu Python 3 (which would have been installed as a dependency of all the other python3 things).

You'll need everything that doesn't start with a python3- to do some of the other compilation.

Without testing it, I imagine that to get Anaconda 3 working on Ubuntu 16.04 (note that Python3 is the system Python on 18.04), you'd just need the same conda installs that you do for macOS, namely:

Code: Select all

sudo conda update -n base conda
sudo conda install -y mpi4py

# get the graphics libraries needed by entering the following in a terminal
sudo conda install -y pyqtgraph
sudo conda install -y PyOpenGL

Re: Installation Issues

Posted: Wed Sep 19, 2018 3:32 pm
by axiezai
Yes I do have pyqtgraph and PyOpenGL installed now, that's not a problem, now the error message I'm getting is:

Code: Select all

Traceback (most recent call last):
  File "", line 9, in <module>
    from morphology import shapeplot, getshapecoords
  File "/usr/local/hnn/", line 8, in <module>
    from neuron import h
ImportError: No module named 'neuron'
I ran your install .sh file as it is, and hnn first told me it couldn't find pyqtgraph, then it couldn't find pyopengl, I re-installed both, and now it's telling me it can't find neuron. I am assuming there's a path-ing issue here, and my best guess is that there was a confusion between the Ubuntu python and Anaconda's python while installing, I could be wrong.

If pyqtgraph, PyopenGL and neuron were installed with the script, they are not being found by the HNN GUI, and having to do another

Code: Select all

conda install
should not be correct. Is there anyway to fix this?

Re: Installation Issues

Posted: Thu Oct 11, 2018 3:01 pm
by ramcdougal
I suggest trying the following to get NEURON to work:

Download and install the .deb from

Then (to allow both Anaconda and your system Python to find NEURON) add the following to your ~/.bashrc:

Code: Select all

export PYTHONPATH=/usr/local/nrn/lib/python/:$PYTHONPATH