nseg shifts depolarization location - extracellular

Anything that doesn't fit elsewhere.
Post Reply
JimH
Posts: 54
Joined: Tue Apr 10, 2007 3:36 pm
Location: Duke University

nseg shifts depolarization location - extracellular

Post by JimH » Fri Jan 25, 2013 4:15 am

Hi all,

I've created a simple axon model with nodes and internodes. The internodes are modeled with a single section and multiple segments. The nodes are modeled as a single section and a single segment. When I provide an extracellular stimulus that is centered on the axon, the maximum depolarization does not occur in the center of the axon (as judged by a low amplitude monophasic cathodic stimulus) unless I set nseg equal to one for the internodes. As I increase nseg for each internode, the site of depolarization shifts towards the root connection (node[0]).

More specifically I am looking at the membrane potential of the nodes (using 21 nodes), and I observe the following:
when nseg = 1 (internode)
the node with maximum depolarization = 11 (1 based) - show typical activating function shape with hyperpolarized side nodes (nodes 10 & 12)
nseg = 2, max node = 8 (again, depolarized center node surrounded by two inhibited nodes)
nseg = 3, max node = 6 ""
nseg = 4, max node = 5
nseg = 9, max node = 3
Some other tested values:
nseg = 18, max node = 2
nseg = 33, no depolarization seen

Using topology, I verified that the cell is connected as I intended.
I've also verified that regardless of nseg, the stimulus I am providing is centered on node 11 (the most negative value is at node 11).
I also verified that the list I am using to hold vectors for recording the membrane potential is going from node[0] to node[20], in order.

The recorded membrane potential looks cropped to one side (towards node[0]) but not cropped on the other side. There are 21 spatial points with different membrane potential profiles over time. In other words, if a sufficient stimulus is given with a high number of nsegs, an action potential clearly propagates from the lower "nodes" to the higher "nodes."

As another interesting twist, I have tried the following manipulations where I can move the stimulating electrode along the axon. When I move the electrode to either extreme (+/-10 mm) for nseg = 9 (internode), the depolarization moves from node 1 at -10mm (node[0]) to 3 (no offset) to node 5 (node[4]) for +10 mm. This shift is generally consistent with my coordinate frame from the stimulus, moving to a negative position along the axon moves the electrode towards node 1. However, it is strange that the stimulus response is centered on node 3, and moves +/- 2 nodes.

If I also choose to record the internodes potentials as well, I get the same behavior except with things centered at node 21, and going to node 1 and node 41 when I move the electrodes to either extreme. As with only recording membrane potential at the nodes, I see 201 spatial segments (9 * 20 : internodes + 21 nodes), with the depolarization in the lower range (i.e. not centered or above spatial segment 100). Also as before, a sufficient stimulus shows propagation from the lower numbered spatial segments to the right.

Any thoughts on what might cause the type of behavior I am describing? My apologies on the difficult wording. I was hoping that in reading this a list of common mistakes would come to mind that I could check. I am stumped though on this one.

Thanks!
Jim

ted
Site Admin
Posts: 5598
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: nseg shifts depolarization location - extracellular

Post by ted » Fri Jan 25, 2013 10:55 am

Zip up just your hoc, mod, and ses files (just enough that I can reproduce what you're seeing), email it to me
ted dot carnevale at yale dot edu
and we'll discuss this off line. At the conclusion of that discussion, I'll post a summary to this thread.

JimH
Posts: 54
Joined: Tue Apr 10, 2007 3:36 pm
Location: Duke University

Re: nseg shifts depolarization location - extracellular

Post by JimH » Sat Jan 26, 2013 1:42 pm

Well in the process of cleaning up the code to zip and send I noticed that I was not properly iterating over the play vectors. Even though I was accessing the correct stimulus voltage given the section and segment I had currently accessed, I was assigning it to the wrong vector.

ted
Site Admin
Posts: 5598
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: nseg shifts depolarization location - extracellular

Post by ted » Sat Jan 26, 2013 2:09 pm

So fixing that took care of the problem? If so, kudos. Debugging is a pain, and it can be especially difficult to find errors in one's own code.

Post Reply