Page 1 of 1

Automake version?

Posted: Thu May 31, 2007 6:38 pm
by mctavish
I have added code to neuron and need to re-run aclocal, automake, and autoconf. (I even tried autoreconf). Everything seems to compile okay, but on install, I get a directory called "@host_cpu@" instead of "i686". When trying to launch the program, it does not work even if I change my nrnenv because any NMODL files are still created and placed in a "i686" directory.

I noted that AutoMake version 1.9.5 was used and I have 1.9.6. I downgraded automake to 1.9.5 (seemingly as aclocal.m4 now says it was created with version 1.9.5), but that does not seem to do the trick.

If I simply run aclocal, automake, and autoconf on the nrn directory, I still get this strange directory name.

Any ideas how to fix it?

Posted: Wed Jun 06, 2007 12:37 pm
by hines
Newer versions of autoconf exhibit this problem and the generic fix was committed to the svn repository for InterViews ... geset/1731
and for the NEURON configure ... geset/1732
(see the file). It is just a one line change to the two files to change

Posted: Wed Jun 13, 2007 6:05 pm
by mctavish
That did the trick, Michael. Thanks!