Debian etch: Installing/Compiling Neuron

Post Reply
tomte
Posts: 1
Joined: Mon Apr 16, 2007 7:46 am

Debian etch: Installing/Compiling Neuron

Post by tomte » Mon Apr 16, 2007 8:01 am

Hi!

I am trying to find a way to install Neuron on a PC with Debian 4 (etch).
Unfortunately i couldn't manage to find any Debian packages so i trieed to compile the nrn & iv packages, following the installation protocol. An this is where i run into a problem. The installation of InterViews worked fine but installation of Neuron (step 3 in the documentation) left me with an error message after entering:
make

readline.c: In function 'rl_read_key':
readline.c:819: error: invalid storage class for function 'next_macro_key'
readline.c: In function 'rl_dispatch':
readline.c:951: error: invalid storage class for function 'with_macro_input'

(and later)
readline.c: In function 'rl_parse_and_bind':
readline.c:5710: error: invalid storage class for function 'substring_member_of_array'

Any idea what to do?
Are there any Debian packages available? The Link to Balbir Thomas' files doesn't work any more.

Regards,
Thomas

hines
Site Admin
Posts: 1577
Joined: Wed May 18, 2005 3:32 pm

Post by hines » Mon Apr 23, 2007 9:14 pm

Code: Select all

readline.c:819: error: invalid storage class for function 'next_macro_key'
These days, most machines already have a libreadline... library and so that directory is skipped and never gets compiled.
So see if you have a system version of readline by checking with

Code: Select all

 find /usr/lib -name libreadline\* -print
or, if you have a 64bit machine, with

Code: Select all

find /usr/lib64 -name libreadline\* -print
and if you do not then I think you will have no trouble finding a debbian package for it and installing it and then starting over from the ./configure step with nrn.

Just curious. Is it unsafe or difficult to use the 32 or 64 bit rpm files for installation on a debbian machine? If that has a chance you can get them from:
http://www.neuron.yale.edu/ftp/neuron/versions/alpha/

hines
Site Admin
Posts: 1577
Joined: Wed May 18, 2005 3:32 pm

Post by hines » Mon Apr 23, 2007 9:26 pm

I just force compiled my readline source code on an x86-64 with gcc 3.4.6 and got no errors. What is the gcc version you are using (you can find out with

Code: Select all

gcc --version
). I'll fix the sources if I can reproduce the error.

Nin
Posts: 41
Joined: Thu May 03, 2007 4:04 pm
Location: Institute of Science and Technology (IST Austria)
Contact:

Post by Nin » Thu May 03, 2007 4:22 pm

I wanted to use the last version of Neuron in Debian, so I transformed the *rpm package into a *deb, and it worked fine for me.

You can find the deb version in my website to download, just here:

http://neurohost.org/index.php/Special:Imagelist

Nin
Posts: 41
Joined: Thu May 03, 2007 4:04 pm
Location: Institute of Science and Technology (IST Austria)
Contact:

Post by Nin » Wed May 09, 2007 5:02 pm

I changed the location, so it's easier to find:
Here the Neuron 5.9 in .deb format ( 4.2 MB)

http://neurohost.org/index.php/Downloads

I hope it works!

Regards!

Post Reply