Compiling NEURON/interviews in UBUNTU

Post Reply
jdsitt
Posts: 1
Joined: Mon Sep 25, 2006 10:08 am
Location: Buenos Aires , Argentina

Compiling NEURON/interviews in UBUNTU

Post by jdsitt »

I am trying to compile Neuron 5.9 in UBUNTU.

When I try to ./configure interviews I get the error :

configure: error: cannot find X11

Ideas ?

ted
Site Admin
Posts: 5769
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Post by ted »


henriklinden

Post by henriklinden »

jdsitt,

i have the exact same problem as you in Ubuntu Edgy. I guess it is one package or the other missing in the linux installation, but have you been able to figure out which one?

Henrik

ted
Site Admin
Posts: 5769
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Post by ted »

Can you compile any source code of anything at all? If not, you probably need the complete
"software developement tools" (which may be called something else by your distribution).
Otherwise, maybe all you need is the X11 development package. Read your distribution's
documentation and follow its instructions.

henriklinden

Post by henriklinden »

yes, I have been able to compile source code for other programs, and I've installed some packages not in my original Kubuntu 6.10 dist for X11, such as libx11-dev, but it doesn't seem to help. When I try to ./configure Interview I get

....
checking sys/conf.h usability... no
checking sys/conf.h presence... no
checking for sys/conf.h... no
checking for X... no
configure: error: cannot find X11
...

Is there a list somewhere over what packages for X11 are needed for installation, or could it be that links are not set up properly?

thanks in advance,
Henrik

PhilippRautenberg
Posts: 15
Joined: Wed Dec 06, 2006 10:53 am

Post by PhilippRautenberg »

henriklinden wrote:yes, I have been able to compile source code for other programs, and I've installed some packages not in my original Kubuntu 6.10 dist for X11, such as libx11-dev, but it doesn't seem to help. When I try to ./configure Interview I get

....
checking sys/conf.h usability... no
checking sys/conf.h presence... no
checking for sys/conf.h... no
checking for X... no
configure: error: cannot find X11
...

Is there a list somewhere over what packages for X11 are needed for installation, or could it be that links are not set up properly?

thanks in advance,
Henrik
Hey Henrik,
try
sudo apt-get install gnome-devel
(if you use gnome. with kde: kde-devel).
If this doesn't help use as well:
sudo apt-get install x-dev
That should work!
happy hacking,
Philipp

csh
Posts: 52
Joined: Mon Feb 06, 2006 12:45 pm
Location: University College London
Contact:

Post by csh »

PhilippRautenberg wrote: sudo apt-get install gnome-devel
(if you use gnome. with kde: kde-devel).
If this doesn't help use as well:
sudo apt-get install x-dev
That should work!
happy hacking,
Philipp
I recently ran into the same problems in Ubuntu (feisty). Although I thought I had installed every single x-development package under the sun (including those mentioned in this thread), config.log still said:

Code: Select all

conftest.c:38:27: error: X11/Intrinsic.h: No such file or directory
Installing libxt-dev finally resolved the problems.

Christoph

dadadel
Posts: 1
Joined: Wed Oct 31, 2007 10:21 am

Post by dadadel »

I had the same problem and I fixed it by installing xorg-dev under ubuntu feisty, if that can help!

Post Reply