Be sure your Linux can compile source code

Post Reply
ted
Site Admin
Posts: 5598
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Be sure your Linux can compile source code

Post by ted » Wed Sep 06, 2006 3:16 pm

Some users who install NEURON from the rpm discover that they are unable to compile
mod files. If this happens to you, perhaps the fault, dear Brutus, lies not in the rpm but in
your Linux installation.

For some time now, many Linux distributions have offered multiple installation
configurations. One of the options may be a "light" or "desktop" configuration, which is a
euphemism for "one step above the stripped down, minimal installation for puny laptops."
Typically this gives you "productivity tools" like OpenOffice, Gimp, a browser, an email
client, and some desktop themes, but that's it. No "sotware development tools," which
means no gcc, and few or none of the libraries that are necessary to generate
executable programs from source code. For example Padraig Gleeson just reported that
a default installation of SUSE v10.0 was unable to compile mod files untill gcc,
ncurses, and ncurses-devel were added. Fortunately, SUSE's yast made it easy to get
the necessary packages.

OS X users have to deal with this too (see
Problem: Mknrndll does not work
in
http://www.neuron.yale.edu/neuron/downl ... _install).

pgleeson
Posts: 6
Joined: Wed Oct 26, 2005 1:43 pm
Location: UCL
Contact:

More packages needed to compile mod

Post by pgleeson » Fri Jan 25, 2008 9:26 am

Hi,

The following packages may also be needed for successful mod compilation:

libsm-devel and python-devel.

Most modern Linux distros will have a package manager which will allow easy install of these.

ted
Site Admin
Posts: 5598
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: Be sure your Linux can compile source code

Post by ted » Wed Feb 09, 2011 5:39 pm

This post by hines
http://www.neuron.yale.edu/phpBB/viewto ... 1268#p6493
from Wed Oct 21, 2009 2:26 pm
lists packages that Ubuntu 9.10 needed to be installed in order to build NEURON from the tar.gz sources, and to build from the mercurial repository. These recommendations seem to be valid for Ubuntu 10.10 as well. Corrections/updates are invited.

Post Reply