upgrade problem in Ubuntu [SOLVED]

Post Reply
fabien tell
Posts: 43
Joined: Mon Mar 25, 2013 1:36 pm
Location: france
Contact:

upgrade problem in Ubuntu [SOLVED]

Post by fabien tell » Wed Aug 08, 2018 5:34 am

Hello,

I tried to upgrade Neuron from 7.4 to the newest version under Ubuntu (14.10 or 18.10). The program installs without problem bu not my old programs don't work anymore I got error mistake when launching them : 64-linux_gnu_ld :cannot find -lncurses and so the libnrnlech.la file failed
Did something change in the command ?

Thanks

Fabien
Last edited by fabien tell on Thu Aug 09, 2018 4:33 am, edited 1 time in total.

ted
Site Admin
Posts: 5370
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: upgrade problem in Ubuntu

Post by ted » Wed Aug 08, 2018 9:45 am

Which file did you use to install NEURON? nrn-7.6.1.x86_64-linux-py-36-35-27.deb, or nrn-7.6.1.tar.gz, both of which are locate in neuron.yale.edu/ftp/neuron/versions/alpha/ .
If you used the gzipped tar file, did an error message about ncurses appear during compilation?

fabien tell
Posts: 43
Joined: Mon Mar 25, 2013 1:36 pm
Location: france
Contact:

Re: upgrade problem in Ubuntu

Post by fabien tell » Wed Aug 08, 2018 10:27 am

Hello Ted,
Hope you're well.
I used the deb file: nrn-7.5x86_64.deb. I did not get an error at this stage.
It happens with any version (or flavour) of Ubuntu .
If I try to install an old version (7.4 or before) I got an error on Ubuntu 18 (missing dependencies) but it works on previous release of Ubuntu (14.10 and before)

Thanks

fabien tell
Posts: 43
Joined: Mon Mar 25, 2013 1:36 pm
Location: france
Contact:

Re: upgrade problem in Ubuntu [SOLVED]

Post by fabien tell » Thu Aug 09, 2018 4:33 am

Hello,

I found the solution by reading this excellent forum :

viewtopic.php?f=6&t=2636

It does work on ubuntu 18.0

Thanks again

Fabien

Post Reply