Python Libraries

Post Reply
HPCGuy

Python Libraries

Post by HPCGuy » Thu Dec 23, 2010 12:47 pm

Hi I am trying to install neuron on centos 5.5. Since it is a standard system on centos the version of python is 4.3.

I am getting errors:

Code: Select all

checking if python include files and libraries work... configure: error: could not run a test that used the python library.
Examine config.log to see error details. Something wrong with
	PYLIB=-L/usr/lib64 -lpython2.4 -lpthread -ldl  -lutil -Xlinker -export-dynamic -R/usr/lib64
or
	PYLIBDIR=/usr/lib64
or
	PYLIBLINK=-L/usr/lib64 -lpython2.4 -lpthread -ldl  -lutil
or
	PYINCDIR=/usr/include/python2.4
1) How do I fix this?
2) Do I need to install a newer version of python or will 2.4 work?

hines
Site Admin
Posts: 1577
Joined: Wed May 18, 2005 3:32 pm

Re: Python Libraries

Post by hines » Thu Dec 23, 2010 1:37 pm

I don't see anything wrong with the the environment variables. You really should look in
config.log to find out precisely why the test failed. I'd guess you have basic python but not
enough of a developer version to actually compile. You should see if Python.h and libpython2.4.*
is anywhere on your machine. If not you should install a python-devel rpm or install python from
sources and use that version to build NEURON.

2.4 will work but if you build Python from sources you might as well go up to 2.6.

Post Reply