--with-gnu-ld is required for compilation on openSuSE 11.2

Post Reply
schmuker
Posts: 11
Joined: Wed Aug 22, 2007 8:18 am
Location: Brighton, UK
Contact:

--with-gnu-ld is required for compilation on openSuSE 11.2

Post by schmuker » Wed Feb 24, 2010 8:16 am

After struggling for some time with this and finally having found the solution, I'd like to share with you that on openSuSE 11.2 I had to use the

Code: Select all

--with-gnu-ld

option for configure. Otherwise, nrnivmodl will not compile any mod files, and terminate with an error message indicating that

Code: Select all

/usr/lib64/libX11.la
is either not found or not a regular .la file (or something similar).

Tested on version

Code: Select all

$> nrniv --version
NEURON -- VERSION 7.2 (401:cc3ce3310b54) 2010-02-15
Cheers,

Michael

Post Reply