Page 1 of 1

RHEL 4 problem?

Posted: Sat Aug 06, 2005 7:01 pm
by carl
I tried to install from the neuron rpm's. When I use nrnivmodl it seems to compile my mod files without errors. But when I try to run I get:

loading membrane mechanisms from /home/carl/fields/neuron/mod/i686/.libs/
dlopen failed -
/home/carl/fields/neuron/mod/i686/.libs/ undefined symbol: _cal_reg

Does anyone know what the problem could be?

Posted: Mon Aug 08, 2005 6:19 am
by hines
The rpm is built on a i686 machine and perhaps there are problems
using that when the shared object is constructed on a x86_64 machine.
However, the specific error message points to something a bit different.
The _cal_reg is derived from the name of the cal.mod file and that
is being called not from outside the but from inside
from a nrnivmodl generated file called mod_func.c. You should take a
look at the cal.c file in the i686 or x86_64 subdirectories and see if
the _cal_reg is defined there. My first thought is that something
went wrong in the cal.mod translation or cal.c compilation which
prevented the library from containing the cal.o file.
You might try removing the x86_64 subdirectory and trying againand making sure there were no errors during the nrnivmodl process. After all, the nrniv executable was able to call the modl_reg function which
crossed the 32 to 64 bit boundary and the failure happened when
modl_reg tried to call _cal_reg which are both on the 64 bit side
within the library.

dlopen failed on an x86 w/ RHEL

Posted: Tue Sep 06, 2005 6:52 pm
by moritz
I also have not been able to load NMODL mechanisms using NEURON 5.7 in RedHat Enterprise Linuz. I get the following error:

loading membrane mechanisms from /home/atm/Bennet sims/i686/.libs/
dlopen failed -
/home/atm/Bennet sims/i686/.libs/ cannot open shared object file: No such file or directory
dlopen("") failed: cannot open shared object file: No such file or directory
JNI_CreateJavaVM returned -1
Info: optional feature Java VM is not present.

Any suggestions for resolving this?
Thanks in advance.

Re: dlopen failed on an x86 w/ RHEL

Posted: Wed Sep 07, 2005 8:35 am
by hines
moritz wrote: dlopen failed -
/home/atm/Bennet sims/i686/.libs/ cannot open shared object file: No such file or directory
First, does the file exist? If so, the problem may be spaces in the path. I only remember supportting path name spaces on mac and mswin. You can edit the i686/special file and try escaping the space with a \. Otherwise remove the i686 directory, rename "Bennet sims" to Bennet_sims and rerun nrnivmodl.
If the file does not exist then wipe out the i686 directory and rerun nrnivmodl and make sure there are no errors during that process.


Posted: Wed Sep 07, 2005 1:03 pm
by moritz
Thanks, yes, it was the spaces in the directory name. I just copied that directory from a mac and didn't even think about the naming...