Page 1 of 1

Installing NEURON on XUBUNTU

Posted: Sun Dec 09, 2007 1:14 pm
by mferran1
Hi everybody,
I'm relativelly new to linux (I'm running Xubuntu). I'm trying to install NEURON on my quadcore machine. I got the RPM 64bit file and I converted it (with alien) to a debian version. Neuron was successfully installed but when I tried to run it from the terminal I got this message:

/usr/local/nrn/x86_64/bin/nrniv: error while loading shared libraries: cannot open shared object file: No such file or directory

Any help?
Thanks in advace,

Posted: Mon Dec 10, 2007 9:48 am
by ted
Sometimes an "error message" is merely a "notification." That may be the case here (unless
you're planning to use Python with NEURON). To find out, open an xterm and type
then select the "Release" demo. Click on the "Init & Run" button. If it runs (graphs will show
a spike and time course of ionic currents and conductances), all the stuff that NEURON
uses every day is fine.

problem persists

Posted: Mon Dec 10, 2007 1:38 pm
by mferran1
Hi Ted, thanks for the reply. If I run neurondemo on the xterm I get the same message :( I've also tried to install the python libraries that are missing but nothing happened... any advice?

Posted: Mon Dec 10, 2007 2:39 pm
by ted
The point of the test isn't to discover whether you get the same msg or not. The question
is whether or not the demo works or not.

Re: Installing NEURON on XUBUNTU

Posted: Wed Apr 22, 2009 3:59 pm
by mferran1
Hi There again,
I run again in the same problem, when in the Xterm I type "neurondemo" neuron comes out but when I click on "init&run" nothing happens...

Re: Installing NEURON on XUBUNTU

Posted: Wed Apr 22, 2009 8:25 pm
by ted
There is a panel with a bunch of buttons labeled
Patch: HH
You have to select a model by clicking on one of those buttons before Init & Run will do anything useful.

So: did you select a model first, and then click on Init & Run?

Re: Installing NEURON on XUBUNTU

Posted: Fri May 03, 2019 4:45 am
by analkumar2
Try these if anybody else encounters this problem:
1) If you are using bash, export LD_LIBRARY_PATH="/usr/local/nrn/x86_64/bin/nrniv"
If you are using tcsh, setenv LD_LIBRARY_PATH /usr/local/nrn/x86_64/bin/nrniv
basically add the path to LD_LIBRARY_PATH. If it works, add the command to the bashrc file so that you don't have to do it everytime you open the terminal. Or, if it does not work,

2) Instead of nrniv, run sudo nrniv. Worked for me.

PS: am noob to linux, so if anyone has any better solution or knows what is going on, please reply.