Bug found(?): Linux Mint 18 with Anaconda

Post Reply
Javier_PalmaEspinosa
Posts: 12
Joined: Tue Nov 10, 2015 5:01 pm

Bug found(?): Linux Mint 18 with Anaconda

Post by Javier_PalmaEspinosa » Sun Nov 06, 2016 12:15 pm

Hi all!

After 3 days of pain, horror, sleep deprivation and other atrocities, I was able to install Neuron in my machine.
The story is more or less like this:
I had worked with python packaged installed by hand (pip install package), and I didn't want to waste time in installing every package that I needed, so I decided to give Anaconda a try. And because it was a fresh started machine with Linux Mint 18, the anaconda process was painless. Also, it was not the first time I installed Neuron in a Linux machine, so I assumed that this was going to be the same thing. A couple of console commands and rock n' roll.

However, things got uglier.
The first one was that making

Code: Select all

./configure --prefix=`pwd` --with-iv=$HOME/neuron/iv --with-blablabla
didn't work, sending me a "cannot link InterViews". DAMN!
I started to update packages (the usual: gcc, libraries and stuff like that), nothing happened. In a moment of divine(?) inspiration(??), I decided to run all the commands using sudo.
That thing worked out quite well. I was able to pass the "cannont link InterViews" thing (YAY to me!), however I started to get weirder messages.

The main issue was that there was some conflict when some software in my machine tried to link the hines*libraries. After hours trying to catch the error, I arrived to the following

Code: Select all

GLIBCXX_3.4.20 not found
I double and triple check in my computer the last updates for those packages (apt-getting and all the usual things that one should do). Still, no changes.
But, after some googling, I found in a forum that

Code: Select all

$conda install libgcc
should work.

Problem solved!! (yay to me, again).

So the question or success that I want to comment here is: Why having conda installed lead to that hard-catching error?
Is that really a bug or some misconfiguration in Linux mint?

Code: Select all

javier@neurolab ~ $ uname -a
Linux neurolab 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

javier@neurolab ~ $ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/5/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 5.4.0-6ubuntu1~16.04.2' --with-bugurl=file:///usr/share/doc/gcc-5/README.Bugs --enable-languages=c,ada,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-5 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-5-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-5-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-5-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.2) 

javier@neurolab ~ $ python
Python 2.7.12 |Anaconda custom (64-bit)| (default, Jul  2 2016, 17:42:40) 
[GCC 4.4.7 20120313 (Red Hat 4.4.7-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
Anaconda is brought to you by Continuum Analytics.
Please check out: http://continuum.io/thanks and https://anaconda.org
>>> 

javier@neurolab ~ $ which python
/home/javier/anaconda2/bin/python
Hope this works to somebody

Mohamed_Hisham
Posts: 10
Joined: Thu Oct 08, 2015 2:56 pm
Location: Wright State University

Re: Bug found(?): Linux Mint 18 with Anaconda

Post by Mohamed_Hisham » Wed Jan 03, 2018 6:00 pm

oh!!, Thank you very much , I already wasted two Days with these Errors

i was trying to compile neuron from source with my anaconda python package

Code: Select all

./configure --with-iv=/usr/local/iv --with-nrnpython=/home/mhisham/anaconda2/bin/python --with-paranrn
and i got these Errors

Code: Select all

M_create(unsigned long&, unsigned long)@GLIBCXX_3.4.21' collect2: error: ld returned 1 exit status
libIVhines.so: undefined reference to `VTT for std::__cxx11:
Makefile:743: recipe for target 'nrniv' failed make[3]: *** [nrniv] Error 1
here is my current machine configuration:

Code: Select all

uname -a
Linux pc 4.10.0-42-generic #46-Ubuntu SMP Mon Dec 4 14:38:01 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

mhisham@pc:~$ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.8.5-4ubuntu4' --with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.8 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libmudflap --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.8.5 (Ubuntu 4.8.5-4ubuntu4) 


mhisham@pc:~$ python
Python 2.7.13 |Anaconda custom (64-bit)| (default, Dec 20 2016, 23:09:15) 
[GCC 4.4.7 20120313 (Red Hat 4.4.7-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
Anaconda is brought to you by Continuum Analytics.
Please check out: http://continuum.io/thanks and https://anaconda.org
>>> 

mhisham@pc:~$ which python
/home/mhisham/anaconda2/bin/python
i thought is was a problem of compatibility so i updated my gcc compiler and downgraded several times but seems as you said it is a problem with the anaconda python package, updating the libgcc has solved the problem

Thanks again

Post Reply