problems compiling .mod

Post Reply
Luisa
Posts: 2
Joined: Wed Aug 01, 2007 5:50 pm

problems compiling .mod

Post by Luisa » Wed Aug 01, 2007 6:17 pm

I'm running OSX10.4.10 and NEURON 6.0.4. I have Xcode developer tools (2.4.1). I'm pretty sure I loaded all of the development tools (I did a custom load).

I've played around with .hoc files and everything seemed to be working until I tried to compile a .mod file. When I dragged the .mod file over the mknrndll window and hit return, the window would simply close. As far as I can tell, new files haven't showed up anywhere.

I'm in the process of double checking to make sure I really did download all of the Xcode tools. But, in the meantime, does anyone know what I might be missing? Or what I might be doing wrong? I'll settle for knowing what actually should happen. :)

Thanks.

Edit: Xcode is all there, and still it won't work.

hines
Site Admin
Posts: 1595
Joined: Wed May 18, 2005 3:32 pm

Post by hines » Mon Aug 06, 2007 6:57 am

Did you download the neuron dmg file
compatible with your binary. If so, then
clicking the nrngui or neurondemo icon
should work. I'm now avoiding the confusion between i686 and powerpc by making universal binaries. See if
http://www.neuron.yale.edu/ftp/neuron/v ... 0.4.10.dmg
works for you.

Luisa
Posts: 2
Joined: Wed Aug 01, 2007 5:50 pm

Post by Luisa » Mon Aug 06, 2007 10:06 am

Thanks for your reply.

I can run nrngui, load hoc files and run neurondemo in either the version I already had loaded or the one you posted just now. The only thing I've found that does not work is generating nrnmech.dll etc. from a .mod file using mknrndll. When I drag a .mod file (either my own or one that came with NEURON) over to mknrndll, a single line (logout?) is printed in the window and the window closes immediately (too fast to read). No nrnmech.dll etc. is generated.

In the meantime, I transfered the .hoc and .mod files I generated over to a PC. On that platform I have compiled .mod files using mknrndll, and .o files and nrnmech.dll show up in the appropriate directory. Everything works. So for now I'm working on that platform. At some point I'd like to get it working on my Mac laptop, though.

Thanks,
Luisa

xiaosage
Posts: 16
Joined: Sat May 11, 2013 10:01 am

Re:

Post by xiaosage » Tue Sep 24, 2013 5:15 pm

Actually I have the same problem and do not know how to solve it..
Luisa wrote:Thanks for your reply.

I can run nrngui, load hoc files and run neurondemo in either the version I already had loaded or the one you posted just now. The only thing I've found that does not work is generating nrnmech.dll etc. from a .mod file using mknrndll. When I drag a .mod file (either my own or one that came with NEURON) over to mknrndll, a single line (logout?) is printed in the window and the window closes immediately (too fast to read). No nrnmech.dll etc. is generated.

In the meantime, I transfered the .hoc and .mod files I generated over to a PC. On that platform I have compiled .mod files using mknrndll, and .o files and nrnmech.dll show up in the appropriate directory. Everything works. So for now I'm working on that platform. At some point I'd like to get it working on my Mac laptop, though.

Thanks,
Luisa

hines
Site Admin
Posts: 1595
Joined: Wed May 18, 2005 3:32 pm

Re: problems compiling .mod

Post by hines » Tue Sep 24, 2013 7:20 pm

Drag the folder containing the mod files onto the mknrndll icon.

xiaosage
Posts: 16
Joined: Sat May 11, 2013 10:01 am

Re: problems compiling .mod

Post by xiaosage » Wed Sep 25, 2013 9:20 am

Hi Mike,

You are right. If I drag the file directly onto the icon, it works! If I first double click the icon and then drag it onto the window, then nothing happens. I guess that might be a problem other people will meet. Thanks for your reply.

Post Reply