Parallel Neuron with Firewall on OS X

General issues of interest both for network and
individual cell parallelization.

Moderator: hines

Post Reply
dave_arthurs
Posts: 6
Joined: Fri Jun 25, 2010 6:52 pm

Parallel Neuron with Firewall on OS X

Post by dave_arthurs » Mon May 19, 2014 7:59 pm

Hi everyone,

I was recently trying to get parallel neuron running, and I encountered a rather strange issue. Essentially, I found that when following the installation and test instructions shown here (http://www.neuron.yale.edu/neuron/downl ... ilestd_osx), I could not run any mpi versions of neuron. I would type a command, such as the following

Code: Select all

cd ~/neuron/nrn/src/parallel
mpirun -n 4 nrniv -mpi test0.hoc
The system would hang for a while and then, after ~3 minutes, return the following

Code: Select all

-------------------------------------------------------
Primary job  terminated normally, but 1 process returned
a non-zero exit code.. Per user-direction, the job has been aborted.
-------------------------------------------------------
--------------------------------------------------------------------------
mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:

  Process name: [[9258,1],2]
  Exit code:    65
--------------------------------------------------------------------------
The first time I ran this, 4 windows would appear asking if I wanted to allow or deny the connection and I clicked allow to all 4.

It turns out, this is a firewall issue and was caused by the McAfee Endpoint Prodection client I was running on my Mac. The three solutions I found were to
1) Unplug the ethernet cable (strangely enough, this works!);
2) Go into McAfee preferences and disable the firewall entirely; OR
3) Go into McAfee preferences, select the "Desktop Firewall" tab, and change the mode from "Regular" to "Adaptive."

Doing ANY of these 3 steps will allow the mpi test to run correctly. I am posting this incase others encounter the same issue, as it took me quite a long time to debug.

Code: Select all

mpirun -n 4 $N/$CPU/bin/nrniv -mpi test0.hoc
numprocs=4
NEURON -- VERSION 7.3 ansi (1078:2b0c984183df) 2b0c984183df
Duke, Yale, and the BlueBrain Project -- Copyright 1984-2014
See http://www.neuron.yale.edu/neuron/credits

I am 2 of 4
I am 1 of 4
I am 3 of 4
I am 0 of 4
I am using Neuron 7.3 on a 15'' Macbook Pro with OS X Mavericks 10.9.2

Post Reply