Search found 35 matches

by MBeining
Fri Sep 08, 2017 12:04 pm
Forum: Parallel NEURON
Topic: parallelized NEURON does not start with pnm.run()
Replies: 7
Views: 9679

Re: parallelized NEURON does not start with pnm.run()

So true... That is a residue from the ParallenNetManager as it says in the description At any rate, before we quit we have to call it so that the master can tell all the workers to quit. pnm.pc.runworker pnm.pc.done Also I found similar lines in your ring network on modelDB https://senselab.med.yale...
by MBeining
Fri Sep 08, 2017 9:05 am
Forum: Parallel NEURON
Topic: parallelized NEURON does not start with pnm.run()
Replies: 7
Views: 9679

Re: parallelized NEURON does not start with pnm.run()

I found the problem.. Without pnm.run() I need to call stdinit() of course ;-)
by MBeining
Thu Sep 07, 2017 12:34 pm
Forum: Parallel NEURON
Topic: parallelized NEURON does not start with pnm.run()
Replies: 7
Views: 9679

Re: parallelized NEURON does not start with pnm.run()

Thank you Ted for the fast reply. I changed the code to work only with the ParallelContext, but the problem stays the same. Here is the complete code: // ***** Initialize Variables ***** strdef tmpstr,simfold // temporary string object objref f objref pc,nil,cvode,strf,tvec,cell,cellList,pp,ppList,c...
by MBeining
Thu Sep 07, 2017 6:39 am
Forum: Parallel NEURON
Topic: parallelized NEURON does not start with pnm.run()
Replies: 7
Views: 9679

parallelized NEURON does not start with pnm.run()

I am very new to parallel NEURON. Currently I try to setup a configuration where 2 cells are simply run in parallel *no NetCons between them". This should later change. However when I run my code, with mpiexec, the neuron instances are in endless loop without something happening. Here is the code (c...
by MBeining
Mon May 15, 2017 4:37 am
Forum: OS X
Topic: Open NEURON in a new terminal together with arguments
Replies: 2
Views: 9630

Re: Open NEURON in a new terminal together with arguments

Thanks Ted for the fast reply and help! My goal is that NEURON stays open. Indeed, the minus sign helps! First I did not suceed using it because it seems to not be possible to copy the Std and Error output of nrniv to a txt file at the same time (using "> outp.txt 2> error.txt") but as the user shou...
by MBeining
Sat May 13, 2017 5:49 pm
Forum: OS X
Topic: Open NEURON in a new terminal together with arguments
Replies: 2
Views: 9630

Open NEURON in a new terminal together with arguments

Hello there, I am having currently a trouble in opening NEURON together with arguments in a new terminal. For example I want to tell NEURON to open without banner and to run a hoc file called "test.hoc". I tried open -a terminal nrniv -nobanner test.hoc but this is not working because the arguments ...
by MBeining
Mon May 23, 2016 12:29 am
Forum: Other questions
Topic: access point process parameters in template
Replies: 2
Views: 1341

Re: access point process parameters in template

Oh, yes I forgot that additional ".cell.number" ... -_- Thank you!
Normally I do not have to type NEURON code since the Matlab interface is doing that for me, but of course you're right, maybe I'll change it for the official version.
by MBeining
Sat May 21, 2016 8:18 am
Forum: Other questions
Topic: access point process parameters in template
Replies: 2
Views: 1341

access point process parameters in template

Hi, I use templates for my morphologies, but also for artificial cells such as NetStim, IntFire etc (is necessary that my Matlab2Neuron interface works properly) begintemplate cell_NetStim public cell public is_artificial objref cell proc celldef() { cell = new NetStim() is_artificial = 1} proc init...
by MBeining
Sat May 21, 2016 8:13 am
Forum: Adding new mechanisms and functions to NEURON
Topic: Cvode problem with a rate-limited SEClamp point process
Replies: 2
Views: 5988

Re: Cvode problem with a rate-limited SEClamp point process

Thank you Ted. I somehow fixed it, however the simulation becomes ultra slow because of low time step. Guess I should not worry that much about those electrode ;-)
by MBeining
Wed Mar 02, 2016 3:31 am
Forum: Adding new mechanisms and functions to NEURON
Topic: Cvode problem with a rate-limited SEClamp point process
Replies: 2
Views: 5988

Cvode problem with a rate-limited SEClamp point process

Hello, I tried to make a "more realistic" SEClamp, by adding a rate in which the voltage is measured and the current updated (normally something like 20 kHz). See this code (actually only some addition in procedure icur was necessary) : NEURON { POINT_PROCESS SEClamp2 ELECTRODE_CURRENT i RANGE dur1,...
by MBeining
Tue Dec 15, 2015 2:34 am
Forum: Anatomically detailed models
Topic: Adding a spine correctly
Replies: 2
Views: 6801

Re: Adding a spine correctly

That makes sense.
Thank you very much!
by MBeining
Mon Dec 14, 2015 7:27 am
Forum: Anatomically detailed models
Topic: Adding a spine correctly
Replies: 2
Views: 6801

Adding a spine correctly

Hello, if I want to add a spine with a neck of (for simplicity) 0.5 µm diameter and 2 µm length and a head of 1 µm diameter and length, I would naively use the following commands: create spine pt3dclear() pt3dadd(0,0,0,0.5) pt3dadd(2,0,0,0.5) pt3dadd(2,0,0,1) pt3dadd(3,0,0,1) The resulting area shou...
by MBeining
Mon Mar 16, 2015 1:46 pm
Forum: Adding new mechanisms and functions to NEURON
Topic: Two channels don't like each other
Replies: 1
Views: 1799

Two channels don't like each other

Hi there, I have some issue with two of my channel models. When I introdruce one of the two channels below, my model works fine, however when I introdruce both channels to my model, cvode gives this error 7 (the corrector convergence failed repeatedly or with |h| = hmin.) or without cvode, the volta...
by MBeining
Tue Jul 08, 2014 2:26 am
Forum: Getting started
Topic: CVODE: record, play, events
Replies: 16
Views: 7508

Re: CVODE: record, play, events

Oh...you're right. Well that might cause problems in my data evaluation. Let's see how I will fix that.
Thank you
by MBeining
Mon Jul 07, 2014 11:54 am
Forum: Getting started
Topic: CVODE: record, play, events
Replies: 16
Views: 7508

Re: CVODE: record, play, events

I have a question related to that. Since I use a multistep IClamp I play the amps into my IClamp with a play vector. However that causes my time vector in cvode mode to have two values which are the same. E.g. if a step is at t = 55 ms, my record time vector has two entries which are exactly 55 ms. ...